Często nasi użytkownicy pytają nas o ostrzeżenie, że wtyczka nie jest testowana z ich wersją WordPress. Czy należy zainstalować wtyczki tej wtyczki? lub znaleźć inną wtyczkę? W tym artykule omówimy, dlaczego należy zainstalować wtyczki nie testowane z wersji WordPress? Co to oznacza i jak możesz pomóc społeczności WordPress?

Po zainstalowaniu wtyczki z obszaru administratora WordPress może pojawić się ostrzeżenie, że wtyczka nie została przetestowana z twoją wersją WordPress.

Plugin compatibility warning

Jak WordPress Nie Otrzymuje Sprawdzonych Informacji?

Oficjalne repozytorium wtyczek WordPress to największa kolekcja darmowych i otwartych wtyczek WordPress. Przesyłając wtyczkę, autorzy są zobowiązani do przesłania pliku “readme” ze swoimi wtyczkami. Ten plik readme jest następnie używany przez katalog wtyczki do generowania strony wtyczki.

Plik readme zawiera “testowane do” znacznik, który służy do wyświetlania informacji. Oczekuje się, że autorzy wtyczek będą aktualizować te informacje.

Oznacza to, że przy każdym wydaniu WordPress autorzy wtyczek powinni przetestować swoje wtyczki i zaktualizować pliki readme dla swoich wtyczek.

Dlaczego autorzy wtyczek nie aktualizują tych informacji?

Wielu autorów wtyczek w ogóle nie aktualizuje swoich plików readme, nawet jeśli testują wtyczkę z najnowszą wersją.

W idealnym świecie chcielibyśmy, aby wszyscy autorzy wtyczek aktualizowali te informacje. Ale nie żyjemy w idealnym świecie.

Pamiętaj, że te wtyczki są bezpłatne i nie płacisz autorom za ich pobieranie i używanie. Autorzy wtyczek czują się mniej skłonni do aktualizacji pliku readme przy każdym wydaniu. Zwykle są zajęci pracą w pełnym wymiarze czasu pracy i płatnymi projektami rozwojowymi.

Video Tutorial

Subskrybuj WPBeginner

Jeśli nie podoba Ci się film lub potrzebujesz więcej instrukcji, Kontynuuj czytanie.

Czy Powinienem Zainstalować Te Wtyczki?

Tak, powinieneś. Tylko dlatego, że autor wtyczki nie zaktualizował swojego pliku readme, nie oznacza to, że nie przetestował swojej wtyczki lub że wtyczka nie działa z najnowszą wersją WordPress.

Jeśli słyszałeś o wtyczce na WPBeginner, możesz bezpiecznie założyć, że przetestowaliśmy wtyczkę z najnowszą wersją WordPress. Jeśli artykuł, na który patrzysz, został opublikowany dość niedawno, oznacza to, że wtyczka jest kompatybilna z najnowszą wersją WordPress.

Z drugiej strony, jeśli wtyczka nie była aktualizowana przez więcej niż dwa lata, oznacza to, że najprawdopodobniej wtyczka została porzucona. W takim przypadku nie należy instalować wtyczki.

Warto zauważyć, że wiele wtyczek, które nie były aktualizowane od ponad dwóch lat, nadal działa bardzo dobrze. Należy je jednak instalować na własne ryzyko.

Jak Możesz Pomóc?

Możesz zainstalować wtyczkę na swojej stronie WordPress i przetestować ją. Jeśli działa zgodnie z oczekiwaniami, wróć do strony wtyczki. Zaloguj się za pomocą swojego WordPress.org nazwa użytkownika i hasło. Następnie przewiń w dół strony, na której zobaczysz sekcję zgodności.

Vote for plugin compatability

Po prostu wybierz swoją wersję WordPress, wersję wtyczki, a następnie kliknij przycisk działa. Robiąc to, dajesz innym użytkownikom znać, że przetestowałeś wtyczkę i działa zgodnie z obietnicą.

Możesz również skontaktować się z autorem wtyczki i uprzejmie poprosić o aktualizację pliku readme wtyczki

Co zrobić, gdy wtyczka jest zepsuta?

Po raz kolejny chcielibyśmy przypomnieć naszym użytkownikom, że jeśli jest to darmowa wtyczka, to autor wtyczki dostarczył ją na zasadzie as-is. Nie ma gwarancji, nawet dorozumianej gwarancji sprawności. Ale pytanie brzmi, jak możesz pomóc społeczności radzić sobie z uszkodzonymi wtyczkami?

Zamiast zostawiać ostry komentarz w wątku wsparcia wtyczki, możesz zostawić konstruktywną i pomocną opinię. Zobacz nasz przewodnik, jak prawidłowo poprosić o wsparcie WordPress i uzyskać je.

Zanim cokolwiek zrobisz, spróbuj zainstalować wtyczkę na innej live lub lokalnej instalacji WordPress. Upewnij się, że możesz odtworzyć ten sam błąd również w innych instalacjach.

Gdy masz pewność, że wtyczka jest zepsuta, po prostu opisz błąd w wątku wsparcia i zostaw go autorowi wtyczki lub społeczności, aby odpowiedziała. Jeśli nie otrzymasz odpowiedzi, możesz spróbować skontaktować się z autorem wtyczki. Większość autorów wtyczek ma informacje kontaktowe na temat swoich WordPress.org strony profilowe.

Jeśli te kroki nie powiodą się, powinieneś odwiedzić stronę wtyczki i zagłosować na wtyczkę zepsutą w sekcji zgodności.

Mamy nadzieję, że ten artykuł pomógł odpowiedzieć na pytania dotyczące tego, czy należy zainstalować wtyczki nie testowane z wersji WordPress.

Jeśli podoba Ci się ten artykuł, zasubskrybuj nasz kanał YouTube dla samouczków wideo WordPress. Możesz nas również znaleźć na Twitterze i Google+.

You May Also Like

Czy należy usunąć “linki” Blogroll na rzecz menu WordPress?

Wczoraj na naszej stronie na Facebooku zadaliśmy pytanie: “gdybyś mógł pozbyć się…

Jak napisać dobry komentarz na blogu i ominąć filtr antyspamowy w WordPress

W artykule: Video Tutorial1. Dlaczego chcesz komentować?2. Bądź pełen szacunku i uprzejmy3.…

Przewodnik dla początkujących, aby naprawić swoją Zhakowaną witrynę WordPress

W artykule: Kilka rzeczy, które warto wiedzieć, zanim zaczniemyKrok 0-poproś profesjonalistę, aby…

Jak edytować wp-config.plik php w WordPress

W artykule: Co to jest wp-config.plik php?Video TutorialPierwsze KrokiZrozumienie wp-config.plik phpUstawienia MySQL…